Application Note:
Windows CE .NET 5.0 Installing Indusoft Web Studio

displays

Description: This application note is intended to assist the system developer in the installation of Indusoft
Web Studio on the IVC Displays Windows CE .NET 5.0 panel PC.

Windows CE Panel PC Runtime Configuration

1. Decide where you will store your Indusoft Web Studio application.

Storage Options:

A. Compact Flash Card ( recommended) — The system refers to the CF Card as StorageCard.
B. USB Flash Drive — The system refers to this as HardDisk.

C. D.O.M. - (When present) — The system refers to this as HardDisk.

File Edit View Go Favorites |[|] «[» =
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S

StorageCard

2. Format the selected storage media.

A. Onyour PC, from Windows Explorer, select the Removable drive and Right click Format the
drive.

Note: Formatting the selected storage media will insure the integrity of the FAT.

3. From the PC copy CEServer.exe to the selected storage.
A. The NP-660T, NP-880S, NP-610S and NP-612S use the ARMV41 version of CEServer.exe.

Copy the Program Files\InduSoft Web Studio v6.1\Redist\Wince 4.0\ Armv4\BIN\CEServer.exe
to the Storage Selected.
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Note: Use a CF card reader on your PC to copy the CEServer.exe on to the CF card. Use a PC USB
port for USB Flash Drive. This may also be done using ActiveSync to the Windows CE Panel PC.

B. The NP-700WX, NP-612X, NP-615X use the Xscale version of CEServer.exe.

Copy the Program Files\InduSoft Web Studio v6.1\Redist\Wince 4.0\XScale\BIN\CEServer.exe
to the Storage Selected.

4. Plug the selected storage in to the Windows CE panel PC.

5. Connect the PC and the Windows CE panel PC to your network. The Windows CE panel PC by
default is set up for DHCP network.

'EP9312 Ethernet Driver’ Settings 0K
IP Address |Hame Servers |

An IP address can be @ Obtain an IP address via DHCP:
autormatically assigned to this
computer. If your network (O Specify an IP address
does not autormatically assion

IP addresses, ask your netwaork IP Address: | g g g |
administrator for an address, cubnet Mask: T T 1 |
and then type it in the space -

provided. Default Gateway: | ' ' ' |

Note: Direct connection from the PC to the Windows CE panel PC will require an Ethernet cross over
cable. You will also have to set the PC IP address and Subnet mask and the Windows CE panel PC
IP address and Subnet mask. Note: The Subnet Mask must match.

To change the Network settings select Start>Settings>Network and Dial-up Connections.

|Ei|E Edit View Advanced ||}(|| o

_
& 2

NGRS e SN 'Epo 312 Ethernet Driver' Settings EE
Connection
IP Address |Name Servers |

A IP address can be (") Obtain an IP address via DHCP
autornatically assigned to this . _
computer, If your network @ Specify an IP address:
does not autornatically assign

IP addresses, ask your network IP fddress: |192 SC B |
adrministrator for an address, Subnet Mask: |255.255 =50 |
and then type it in the space =

provided, Default Gateway: | . . . |
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Note: After making changes on the Windows CE panel PC you must use CECP to save the registry.
If not the settings will be lost when you reboot.

Select the Save tab then Save Registry.

[LCD Settings IMAC address | Save |5y5tem vel 4] »

Save reqgistry

Backup registry to CF Card

Restore registry from CF Card

Registry is saved.

[LCD Settings IMAC address | Save |5~_.f5tem ve 4] >

Ii Reqgistry save successiull

Backup registry to CF Card

Restore registry from CF Card

_____________________________________________________________________________________________________________________________________|
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6. Execute CEServer.exe

From the Windows CE desktop select Start>Run>Browse and select your HardDisk or Storage card,

where you copied the CEServer.exe from your PC. Then select CEServer.exe. Select OK to run
CEServer.exe.

L

_onneckion status:
|N|:|t connected to remate client

Long:
Runtime was started,

Device cannection via Sekup
Metwork (TCPIIP)

Stark

duy

Local IP: 192.168.1.104 Exit
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Development System PC Configuration
7. Toinsure the PC and the Windows CE panel PC are able to communicate, Ping the IP address of
the Windows CE panel PC form the PC.

On the PC select Start>Run

Enter cmd and select OK.

Fun \

= Type the name of a program, folder, document, or
Internet resource, and Windows will open it For yaou,

-

open: | cmd| W

[ (9] 4 ][ Cancel ][ Browse. ..

A command line window will display. Enter ping followed by the IP address of the Windows CE panel
PC. (ie. ping 192.168.1.104)

Microsoft Windows NP [Uerszion 5.1.268081]

B J\WINDOWS\system32\cmd.exe -0 ﬂ
(C» Copyright 1985%-20P01 Microsoft Corp. I’

J=“\Documents and Settings“Kenrping 192.168.1.184
Pinging 192.168.1.1684 with 32 hytes of data:s

Reply from 192.168.1.1084: hytes=32 time=1ms TIL=128
Reply from 172.168.1.184: hytes=32 time=1
Reply from 192.168.1.1084: hytes=32 time=1
Reply from 192.168.1.184: bhytes=32 time=1lms TIL=128

Ping statistics for 192.168.1.184:

Packetsz: Sent = 4. Received = 4, Lost = B (@x loss),
Approximate round trip times in milli-seconds:

Minimum = imsz, Maximum = 1ms,. Average = 1ms

J=“Documents and Settings“Ken>

If you do not receive a reply the PC and the Windows CE panel PC are not communicating.
To close the command line window type ‘exit’.
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8. From Indusoft Web Studio select Project>Execution Environment or the Icon =

* InduSoft Web Studio |Exeu:uti|:|n Envirnnmentk
File Edit Wiew Insett | Projeck | Tools ‘Windaow  Help
3@ ®d Settings...
ﬁ |: Status. ..

= 3 Project: test.AP

(1] screens Bl Run Application

(1 Group Screen | @ Stop Application

([ web Pages

[ swmbals ﬁ Execution Environment., .,
(1= I

9. Select the Network radio button and enter the Windows CE panel PC IP address and then click the
Connect button.

Execution Environment X|

Targst |;‘-‘-.|:||:|Ii|:ati-:|n| Impart I CE License I

~ Target Station Connect | Disconmect |
" Local Status:
= Network . [ 192.168.1.104 |

. Platform:
i~ Serial Port: I.:c”*g vI .ﬂ.dvanced...l I

" Microzoft ActiveSync

Imstall =ystem files. .. ||7 Dl mewvet files

Close

. ______________________________________________________________________________________________________________________________________|
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10. The Status line will inform you if the PC is connected to the Windows CE panel PC.

Execution Environment X|

Targst |;‘-‘-.|:||:|Ii|:ati-:|n| Impart I CE License I

— Target Station Conmect |

= Locs| bt ‘ \
@ tetwork ;[ 192.168.1.104 @t” SRz LDt
: Platform:
) Serigl Baort: I.:.:;|'3 vI Adyanced.. | I*'-.flr-JCE 20+ ARMVA]
L . Ll

) Mictosoft SctiveSyne

In=ztall zy=tem files... ||7 Only newer files

Close |

Remote Agent on the Windows CE panel PC with status connected.

Remote Agent {v6.1)

< iCDnnected ko remoke n:Iiep

M —
Log:

Runtime was started,

X

Device cannection via Sekup
Metwork (TCPIIP)
Stark

Local IP: 192, 168.1,104 —

d
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11. Select the Install system files button. You will see the files being copied in the Remote Agent
windows on the Windows CE panel PC.

Execution Environment X|

Targst |Pnppli|:ation| Impart I CE License I

— Target Station Conmect |

€ Locsl Status:

@ tetwork ;[ 192.168.1.104 | connected to CEView ve.1+5Pe

Platform:
" zerial Port g
B I'*C'”? || Zavanced | [WiNCE £.0 + ARMVeI

) Mictosoft SctiveSyne

Inztall zystem files... ||F Only newer files

Close |

12. When the system files are installed then select the Application tab. Then select the ‘Send To Target'
button to Upload the Indusoft application to the Windows CE panel PC.

Execution Environment X|

Target Application | Impart I CE License I

Application Path
Local: I t= and Settingz\Ken\My DocumentstinduSeft Web Studio w5.1 Project\CEtest)

Target: | HardDisk\CEtest| -

¥ Onby newer files
Send To Targst Status:
_sendToTarget [ e |
Send File... | Stop |

Close |

. ______________________________________________________________________________________________________________________________________|
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13. You will see the files being copied in the Remote Agent windows on the Windows CE panel PC.

X

Remote Agent (v6.1)

_onneckion status:
knnnected ko remate client

with success,
Ilpdating File Y\HardDisk\Binl CEYiew. exe.

Device cannection via Setup
Metwork (TCPITP)
Skart

Exit

Local IP: 192,168.1.104

14. The Status line will inform you when the file upload is successful.

Execution Environment x|

Target Application | Import I CE License I

Application Path
Local: Its and Settings\Ken\My DocumentziinduSoft Web Studio w5.1 Project=\CEtesth

Target: | \HardDisk\CEtest\

Send To Taraet ¥ Onb newer files
ull_ Kesp user files
Send File... |

_____________________________________________________________________________________________________________________________________|
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15. To test your application you my select Run from the Application tab of the Execution Environment on
the PC or the Remote Agent Start button, on the Windows CE panel PC.

Execution Environment x|

Target Application | Import I CE License I

Application Path
Local: Its and Settings\Ken\My DocumentziinduSoft Web Studio w5.1 Project=\CEtesth

Target: | \HardDisk\CEtest\ |
¥ Qnly newer files
Ssend To Targst |I_ Keep user fies Run Stafuss
p Application was startedj
Send File... |
Close |

If your Windows CE panel PC is not licensed for Indusoft Web Studio runtime, you will be notified
that the system in Demo mode will only run for two hours.

Irwalid license!

Demo moce active, The system will run for two howrs,

16. To stop the application on the Windows CE panel PC select the Stop button on the Execution
Environment, Application tab form.

The status line will inform you that the application was stopped.

Execution Environment El

Target Application | Impart I CE License I

Application Path
Local: Its and Settingz\Ken\My Documentz\induSoft Web Studio v8.1 Projectz\CEte=tl

Target: | \HardDisk\CEtest, |

v Only newer filez
[ Only Run Status:

Send To Target
= g [T Keep user filez =

Send File... |

I Application was stopped.

Close |
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CE License

17. To register the Indusoft Web Studio License onto the Windows CE Panel PC, select the CE License
tab.

18. Mouse select the Site Code and Ctrl-C to copy it to the clipboard.

B | . .
19. Or, use the icon to copy the Site Code to the clipboard.

F ]

Execution Environment

Target | Application | Impart | CE License

Licenze Settingz
Product Type: | Mot licensed yet.

Wersion: Web Thin Clients: Secure Wiewers:

Licenze Codes
Site Code: | 9328 E336 951F 9534 BF A4 6ADC 0374 9839 3E

Site Hey:

Cloze

20. Open a new email and paste the Site Code into the body with Ctrl-c. Or, Right click paste.

21. Send the email to support@ivcdisplays.com.

22. You will receive an email with the Site Key.

23. Simply copy the Site key and paste it into the Indusoft CE License of the Execution Environment.

Execution Environment

Target | Application | Impart | CE License

Licenze Settingz
Product Type: | Mot licensed yet.

Wersion: Web Thin Clients: Secure Wiewers:

Licenze Codes
Site Code: | 9328 E336 951F 9534 BF A4 6ADC 0374 9839 3E

Site Key: | 1245678901 2345678901 2345678380
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24. Then Use the Send button to send the Site key to the Windows CE panel. The Site key is written to
the project on the location of CEServer.exe.

25. Note: We suggest that the CEServer.exe is placed in a removable media such as CF card or USB
Flash Drive.

Configure Windows CE application Launch on Boot

26. Select Start>Windows Explorer.

fﬁ Programs
'fg Faviorites r
D Docurnents  *
[F Settings *
ZFRUn...

#E cornmand Prompt
ﬁ Intetnet Explorer
.':;.‘ Windows Explarer

27. Navigate to your HardDisk or StorageCard, what ever you selected in step. Select CEServer.exe and
Edit>Copy the file.

File m View Go Favorites

(I =S

[x]
I]] add Lindo Ctrl+Z EI
Cut Chrl+x . WS
* o
Copy Ctrl+C V -"/ _,,/ LR
Bl paste Ctrlew FST test 405-hi[1]  AUTOEX.. CEAppINI
Paste Shortout ATV .
Select Al Ctrl-2 j . . ' .
CERDISP.. Clock ME... HMISCADA... wstlspd ... MSASYM.., Mk BIM ProfiBus_I...

aﬁfll

rernoteds,,, Robotswiy Windows_..

28. Navigate to folder NORFLASH)/Startup folder and Edit>Paste Shortcut of CEServer.

_____________________________________________________________________________________________________________________________________|
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File m View Go Favorites ||]] e pd el |
I]] Add Lndo Delete Ctrl+2 EI
Cut CHrl4x
Copry -
Paste el

Paste Shaortout

Select Al Ctrl4-2

29. You will see the Shortcut to CEServer. Close Windows Explorer.

File Edit View Go Favorites ||]] al» > = |
I]]ﬂ.ddrESS I YWORFlashi Startup EI

Shortout to
CEServer.nk

30. To Hide the Windows CE Task Bar select Start>Settings>Task Bar and Start Menu...

[ Control Panel
& Metwork and Dial-up Connections
o, Taskbar and Start Menu.,..

31. Check Auto hide and click OK.

Taskbar and Start Menu Properties m

General | Advanced |

[ &bways on top
Auto hide

32. From the desk execute CECP.
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33. From the Save tab select Save registry. This will save your settings on NORFLASH/Startup.

[LCD Settings IMAC address | Save |5y5tem vel 4] »

Save reqgistry

Backup registry to CF Card

Restore registry from CF Card

[LCD Settings IMAC address | Save |5~_.f5tem ve 4] >

Ii Reqgistry save successiull

Backup registry to CF Card

Restore registry from CF Card

Comments:
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Do not place CEServer.exe into NORFLASH/Startup. The Execution Environment will install the application
in NORFLASHY/Startup and crash because there is not enough memory.

Save the registry with CECP to save changes to Windows CE.
When updating to a new version of Indusoft Web Studio (e.g. SP4, SP5...), you need to make sure to copy

the new version of CEServer. Also, when doing so, you should download all system files, not just newer
(good idea to start fresh).

Address any comments or questions to support@ivcdisplays.com.
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